Problem with most samples

Dec 9, 2011 at 8:12 PM

I'm using VC++ Express (2010), making a Debug build.  Everything appears to build.  However, BasicApplication is the only one that runs.  Some of them just crash; others say that "Error compiling shader program ... " and crash.  ViewFromTheWindow puts up several windows and crashes.  Others fail an assert.

 

Any help would be greatly appreciated.

Dec 10, 2011 at 6:18 AM

Hello,

It isn't likely that VC++ Express is a problem. I would suggest first to test with the reference device. See the documentation tab there is a topic "How to run with the reference driver". When trying, be patient, some sample take very long time to execute because the reference driver is actually implemented by Microsoft using standard hardware, not the GPU.

I would also suggest looking for the very latest driver for your video card.

-- Francois Piette

Coordinator
Dec 10, 2011 at 9:29 AM

Do you have the Windows SDK and the June 2010 DirectX SDK installed?  Also, is there any output in the Debug output window generated before the applications crash?

Dec 10, 2011 at 7:43 PM

Thank you both for your responses! 

I had the June 2010 DirectX SDK, so I got the Windows SDK 7.1 and now the apps all run!  However, I noticed afterward that I had had the Windows SDK 7.0 all along, though, so I'm not sure I understand why it didn't work before.

-Rich Rubin

Coordinator
Dec 11, 2011 at 6:03 AM

To be honest, I'm not sure what the differences are between 7.0 and 7.1, but there must be something different that the samples are depending on that isn't there in 7.0.  It could also be that if you had the 7.0 SDK installed before you installed VS2010 that the directories were set up properly with the IDE.

In any case, I'm happy that the issue is resolved!

- Jason