This project is read-only.

Hieroglyph3_Desktop.lib not being built

Jul 13, 2015 at 8:24 PM
Edited Jul 14, 2015 at 11:42 AM
I've followed all instructions for downloading and building the engine.
I'm using Windows 7 and MS Visual Studio Express 2013 for Windows Desktop.
Everything loaded up and compiled without a hitch, but the Build ended off with 'fatal error LNK1104: cannot open file 'Hieroglyph3_Desktop.lib'
Also, trying to build any of the projects gave the same error.
The 'C:\Hieroglyph3\Library\Win32\Debug' folder contained only the files 'Hieroglyph3_Desktop.idb' and 'Hieroglyph3_Desktop.pdb' and no 'Hieroglyph3_Desktop.lib'

There was also one other error whilst compiling the 'BasicApplication_Desktop' project...
4   IntelliSense: identifier "D2D1_PIXEL_FORMAT" is undefined   c:\Program Files (x86)\Windows Kits\8.1\Include\um\wincodec.h   943 5   Hieroglyph3_Desktop
A Google search lead me to this:

Maybe this is related to the 'Hieroglyph3_Desktop.lib' problem ?
Jul 15, 2015 at 9:52 AM
I managed to fix this by changing the Project Property Settings / Configuration Properties / VC++ Directories for the 'Hieroglyph3_Desktop' project as follows:

Include Directories: C:\Program Files %28x86%29\Microsoft DirectX SDK %28June 2010%29\Include;$(IncludePath)
replaced with $(WindowsSDK_IncludePath);$(IncludePath)

Library Directories: C:\Program Files %28x86%29\Microsoft DirectX SDK %28June 2010%29\Lib\x86;$(LibraryPath)
replaced with $(LibraryPath)

Exclude Directories: $(VC_IncludePath);$(WindowsSDK_IncludePath);$(MSBuild_ExecutablePath);$(VC_LibraryPath_x86);
replaced with $(VC_IncludePath);$(MSBuild_ExecutablePath);$(VC_LibraryPath_x86);

All the projects now compile and run successfully.